Setting Transparent Web Proxy Server di Mikrotik Router OS

By On Friday, April 21st, 2017 Categories : Sains

(Setting Transparent Web Proxy Server di Mikrotik Router OS) – Proxy server merupakan program yang dapat mempercepat akses ke suatu web yang sudah diakses oleh komputer lain, karena sudah di simpan didalam caching server. Transparent proxy menguntungkan dalam management client, karena system administrator tidak perlu lagi melakukan setup proxy di setiap browser komputer client karena redirection dilakukan otomatis di sisi server.

Bentuk perintah konfigurasi :
a. Setting web proxy :

– ip proxy set enable=yes
port={ port yang mau digunakan }
maximal-client-connections=1000
maximal-server-connections=1000

– ip proxy direct add src-address={ network yang akan di
NAT} action=allow

– ip web-proxy set parent-proxy={proxy parent/optional}
hostname={ nama host untuk proxy/optional}
port={port yang mau digunakan}
src-address={ address yang akan digunakan untuk koneksi
ke parent proxy/default 0.0.0.0}
transparent-proxy=yes
max-object-size={ ukuran maximal file yang akan disimpan
sebagai cache/default 4096 in Kilobytes}
max-cache-size= { ukuran maximal hardisk yang akan
dipakai sebagai penyimpan file cache/unlimited
| none | 12 in megabytes}
cache-administrator={ email administrator yang akan digunakan
apabila proxy error, status akan dikirim
ke email tersebut}
enable==yes

Contoh konfigurasi
a. Web proxy setting

/ip web-proxy
set enabled=yes src-address=0.0.0.0 port=8080 \
hostname=proxy.routerku.co.id transparent-proxy=yes \
parent-proxy=0.0.0.0:0
cache-administrator=support@routerku.co.id \
max-object-size=131072KiB cache-drive=system max-cache-size=unlimited \
max-ram-cache-size=unlimited

Nat Redirect, perlu ditambahkan yaitu rule REDIRECTING untuk membelokkan
traffic HTTP menuju ke WEB-PROXY.

b. Setting firewall untuk Transparant Proxy
Bentuk perintah konfigurasi:

/ip firewall nat add chain=dstnat
protocol=tcp
dst-port=80
action=redirect
to-ports={ port proxy }

Perintahnya:
/ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080 \
comment= disabled=no
add chain=dstnat protocol=tcp dst-port=3128 action=redirect to-ports=8080 \
comment= disabled=no
add chain=dstnat protocol=tcp dst-port=8000 action=redirect to-ports=8080 \

perintah diatas dimaksudkan, agar semua trafik yang menuju Port 80,3128,8000 dibelokkan menuju port 8080 yaitu portnya Web-Proxy.

CATATAN:
Perintah
/ip web-proxy print { untuk melihat hasil konfigurasi web-proxy}
/ip web-proxy monitor { untuk monitoring kerja web-proxy}

The Bohemian and the Businessman (The Story Sisters #1), Salvation's Inferno, Sweet Tooth, Razr (Demonica, #11.8; Demonica Underworld, #4), Heels, Heartache & Headlines (Hollywood High #5), The Girl of Fire and Thorns (Fire and Thorns, #1), Emmanuel's Dream: The True Story of Emmanuel Ofosu Yeboah, The Oster Conspiracy of 1938: The Unknown Story of the Military Plot to Kill Hitler & Avert World War II, The Crows of Pearblossom, DILF: A Secret Baby Bad Boy Romance, Normal (Fearless, #31), Good Lies (Wild Minds, #1), The Weight of Zero, American Assassin (Mitch Rapp, #1), The Guernsey Literary and Potato Peel Pie Society, Cowboy Car, Force Of Nature (Joe Pickett, #12), The Girl Next Door (Carter Ross, #3), Over and Under the Pond, The Nightingale